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Short description of the system 

 
With Maintenance Master you can keep track of ship components and jobs that needs to be 

addressed. You can also print reports about jobs that have been finished or needs to be 

addressed in the near future. For data that have expiration date, it is possible to set up email 

notification on the office version, so you can get warnings about data that are about to expire 

or that have already expired. You can also get an overview of expired data in the ship version 

by searching for expired jobs or viewing it in a report. 

 

This document describe the features of v5.2 of the program. 

 

 

Overview of the main window: 
 

 

 

 

From the main window, you can add, edit and delete main and subcomponents (on the left 

hand side of the window), edit jobs, specifications, spare parts and look at jobs that have been 

signed out (history). You can also look at expired jobs (search), reports and edit the running 

hour main list. 
 

 

 

 

 

 

 

 

 



 

Adding and updating components 
 

The program lets you add, edit and delete main and sub components (left hand side in the 

main window). 

 

This is how to add a main component and then a sub component: 

 

To add a main component, click “Add main component” from the menu that pops up when 

you click the add button under the component list.  
 

 

 

 

 

Enter the number and name for the component: 

 

 
 

To add a subcomponent to the newly added main component, select “Add sub component” 

from the menu that pops up on the add button. 
 



 
 

In the add component window, enter the subcomponent number and name: 

 

 
 

Figure below shows how it looks for the main component and subcomponent that we added 

above: 

 

 
  
 

Note: You can create sub components of sub components as well. For example if you create a 

sub component 600.01.02 it will end up under the 600.01 sub component. 

 

Note also that you can add, edit and delete components from several places in the program. 

From the buttons as mentioned above, or from two different menus. The top menu let you add 



main components (shortcut Ctrl + M) and sub components (shortcut Ctrl + J) as shown in the 

figure below: 
 

 
 

 

 

By right clicking on the component list, you get a menu that let you select add, edit and delete 

components, in addition to a couple of other options: 
 

 
 

The expand and collapse options above are for expanding and collapsing the content of the 

current tree item. So if you do the expand on the main component, all the sub components will 

be expanded in the tree so you can see all the components listed under the main component 

without clicking on each plus sign to open each sub component. Collapse do the opposite (un 

expand).   
 

 

 

Duplicate component tree: 
 

To duplicate (copy a component tree). Right click in the component tree: 

 



 
 

When selecting the duplicate component tree option, the following windows will pop up: 

 

 
 

A new main component will be suggested based on an available component number. In this 

window you can copy parts of the original tree or all of the tree structure. 

 

In addition you can copy all components specifications, jobs and spare parts. If the component 

that is copied have running hours attached to it, the components running hours from the 

running hour main list will also be copied and attached to the new components. 
 



 

Running hour main list 
 

Some components use running hours (for example engine parts) instead of expiration date. To 

enable running hours for a component, add it to the running hour list: 

 

 
 
 

Note that in the figure above, two main components have been added to the running hour list. 

Main component 413 and 220. All jobs, including jobs that are added to subcomponents of 

413 and 220, for example subcomponent 413.01 and 220.11, will all have the option to select 

running hours when you add a job for the component. All sub components will use the main 

components running hours (as in the example above) unless you add sub components with its 

own running hours into the list. In that case the subcomponents will use the running hours of 

the nearest owning component in the running hour list. 
 

 

 



 
 

In the figure above, a job is added to the 220.11 component. As you can see above, you can 

select to either use running hours or date for this job, because the running hour have been 

added to the running hour main list for the component that this job is attached to.  

 

In addition there is a tab for spare consumption. With this tab you can set up which spare parts 

to be consumed when signing out a job. The details of how to use this feature is covered in the 

spare parts section further down in the documentation. 
 

The job types and departments can be changed from the main menu Edit->Options. 

 

 

Adding and signing out jobs (create history) 
 

Under the main window, you can add, delete, edit, sign out jobs and postpone jobs. In the 

window below you can see how it looks when editing a job: 

 



 
 

As you will notice from the figure above, for this type of job it is not possible to select 

anything for the R hour’s interval (running hour interval) and Expired (Running hours). To be 

able to create jobs that use running hours, you have to add the main component (or 

subcomponent) that this job is related to, in the running hour list (see the running hour list 

section above).  

 

 

 
 

The “certificate info” button in the edit job window above is only available when you create 

jobs for the 112 Certificate and its subcomponent. 

 



 
 

 

When you press the sign out button under the jobs list in the main window,  
 

 
 

a window will pop up where you can insert expire date / running hours, information about 

who signed out the job for (automatically filled out if specified initials for logged in user) and 

description of what was done: 
 



 
 

 

There are some validation when completing jobs to assure no errors are made when 

completing jobs such as: Not possible to complete jobs further back then one job interval from 

expire date. And will not complete jobs that are into the future (more then today's date). 

Postpone job in cases where not possible to complete on expired date or running hours. 

 

In addition it is possible to override spare parts that will be consumed. In the window that pop 

up when clicking the .. button next to consume spares, you can select which spare parts that 

will be consumed, override number of items to consume, and add more spare parts that will be 

consumed. See spare part section for more information. 
 

When job is completed (signed out) you will create a history item under the history tab on 

component for the job that you just signed out. 

 

If the job expired many intervals ago and the user try to complete a job many intervals later, a 

new window will show up that let the user easily complete multiple expired intervals at the 

same time, to close up the interval gaps. The window that pops up are shown in the window 

below: 
 



 
 

In the window you can see that the expire date was 18.08.2013 and the job is being completed 

on 09.06.2015, job interval is 6 months. So between those dates there were 4 intervals that 

have expired and one that is being completed before expire date (the last item). If the same 

thing need to be completed on each interval, the easiest thing to do in those cases, is to first 

double click on the first interval (18.08.2013) to edit. Then write who completed the job (if 

other then the default) and what was done. Copy (Ctrl + C) the description of what was done, 

and double click the next one (or click the edit button), then paste (Ctrl + V) in the what was 

done data. The items that have a checkmark next to them will be completed (signed out). 

 

To see the history items that was created when completing these two jobs, see the jobs 

analysis section below. 

 

 

 

Copy job: 
 

To copy a job, right click on a job in the job list.  

 

 



 
 

This will bring up the job window: 

 

 

 
 

The information that is copied on the jobs is: Job type, interval, expire date or running hours 

and department. The expire date is based on the running hour or expire date from the previous 

job. To change the expire date or running hours to be based on the current date + interval, 

change the interval date or running hour interval. That will update the expire info based on the 

current date. 



 

Job status: 
 

 
 

On the jobs list, the status column show the status of the jobs. The colours in the status 

column mean: Red - expired job, orange - job will expire within the next 30 days, green mean 

that it is more then 30 days until the job will expire. 

 

 

Job analysis 

 
Under the jobs tab (mentioned above) there is also a button for job analysis. The window that 

pop up when you click on the button, is shown below: 

 

 

 
 

 



With the job analyse option, you get an overview of the history on the job, and also how many 

days or running hours each job was overdue (either completed before due or after due date / 

running hours). 

 

The option is available from the main window, under the jobs tab, or from the search result 

window. 

 

The "show system log items" checkbox is for filtering out log events. By default the system 

log events (such as change of interval etc) is not displayed. To display the system logs items, 

check the checkbox. 

 

 

 

Adding specification 
 

To add a specification to a main component, or subcomponent, press the specification button 

under the main window. See window below: 
 

 

 
 

 

 

 

 

Spare parts 
 

You can add spare parts from the spare parts tab on the main window, by first selecting the 

component and then adding spare parts on the component.  
 



You can set up that spare parts can be consumed when you sign out a job. When consuming a 

spare part, the units and units prices will be stored so you can get the information out in a 

report or on the spare part more info window. 

 

To set up consumption of spare parts: 

 

1. Add a spare part to a component. 
 

 
 

NOTE: Currency is based on the settings in your computer. In the case above the settings is for 

Norwegian krone. 

 

2. The added spare part can now be attached to a job for auto consumption when signing out a 

job: 
 



 
 

In the window above 1 spare have been set up to be consumed automatically. You can also 

change the number of units to consume. Lets say you would like 2 filters to be consumed 

when you sign out the change filter job. To do that, just click edit spare, and change the 

number to 2. 

 

 

3. When signing out a job, you can override the default auto consume settings that where 

defined on the job (defined in the previous step), by clicking the .. button on the sign out 

window below: 
 



 
 

The following window will pop up when you click the button: 
 



 
 

In this window you also get an overview of the price of the spares that will be consumed. You 

can add and remove other spares as you need them.  

 

4. An overview of the price and number of spare parts that have been consumed over time, 

can be found in the spare part more info window: 
 



 
 

 

The information is also available in a spares consumed report (see report section for more 

info). The mentioned report is grouped by date, so you get an overview of what the price was 

for spares consumed on a particular day. The filters that you can choose from in the report 

include date from - to, supplier, category and department. 

  

 

Add and update supplier list 
 

In addition to adding a supplier from the add spare parts window, you can also add a suppliers 

from the menu Edit->Add supplier. The window that pops up is as below: 

 



 
 

 

 

Search for expired jobs 
 

To search for expired jobs, press the find button in the main window and select the Expired 

jobs option in the dropdown menu. The window that pops up lets you search for expired jobs 

by either today's date or specifying expired jobs. 

 



 
 

 

The jobs expired now option, search for date and running hour jobs that have already expired. 

The specified expired jobs option let you search for jobs that have expired or will expire in the 

future. 

 

With the filter, you can filter out the type of expired jobs that you would like to be displayed.  

 

When the search is completed, you will get a search result window, where you can sign out, 

postpone, do job analysis and get more job information. 

 



 
 

 

Unplanned events 
 

An unplanned or unscheduled event, is an event without expire information and that happen 

only once. For example, a replace of one engine with a new engine. The unplanned event 

functionality is used for recording the event, and will show up in the history only. When event 

occurs that affect jobs on the component (such as replace engine example), it would be 

necessary to update all affected jobs (with zeroed out running hours and new expire dates) and 

also update running hour main list. 

 



 
 

 

To access the functionality either click on the main menu Edit->New unscheduled event 

option or right click on the component in the component list and select add unscheduled event 

menu item. 

 

 

 

Postpone job 
 

The postpone window is for changing the expire info of the job, in cases where the job could 

not be completed in the planned expire date / running hours. When postponing a job, it is 

necessary to specify new expire info and a reason for postponing the job, so that it is possible 

to track the change in the history of the component. The postpone button is available from the 

jobs tab in the main window: 
 

 
 

When you press the button, the following window will pop up: 
 



 
 

 

When postponing the job. The job expire date will change to the new expire date / running 

hours. In addition a new entry will be made in the history of the job so it is possible to see at a 

later time why it was postponed. 

 

 

General search: 
 

The general search window is available from the find button in the main window. 

 

 
 

When you click on the menu item, a new window will pop up: 

 



 
 

In this window, you can search for components, jobs, specifications, spare parts, suppliers and 

history. 

 

In the jobs tab you can for instance search for all in the Machine (M) department, by selecting 

the Equals query option in the dropdown above the search button and then entering M in the 

search for criteria. 

 

With the "goto" button. You can goto the component, spare part etc in the main window. 

 

 

Task list: 
 

You will find the "Task list" from the find button in the main window. 

 

 
 

 



The task list is for getting an overview of the jobs that have expired, will expire in the next 30 

days, will expire in 31-60 days or have been completed the previous 30 days. Note that the 

lists are sorted by component number to better find the information that you are looking for. 

 

 
 

 

Note also that the Total expired, total due next 30 days, total due next 31-60 days and 

completed last 30 days are default based on all jobs in the system. Those values will be 

updated based on the filter that you put into the filter part of the task list window.  

 

On the different lists there are also various menus available (different menu on the completed 

list): 

 

 
 

On those menu items you can get more job info, sign out job, postpone jobs or analyze the job 

in more details etc. 

 



 

 

Create backup 

 

 
 
To create a backup, select File->Create backup. When the backup is done you can use this 

backup on the multi user (office) version to import the boats data, or keep the backup so that 

you can restore the database to the state of the time of backup. 

 

To restore a backup select File->Restore backup from file. Or click at the backup button at the 

bottom right corner of the main window. 

 
It is recommended that you create backups on a regular basis, and keep a good routine of 

creating backups. Create a new backup at least once a week. 

 

 

Auto backup: 
 

A backup is automatically created each time the program starts. If the program is unable to 

run for any reason, an attempt will be made to restore the database to the state which it was in 

before the database because corrupted (last successful backup made). 

 

 

Auto update: 
 

Each time the program start, it will default check for updates. If a new version of the program 

is found, the window below will pop up. If you answer yes. The needed files will be 

downloaded and the update will be executed. Program will restart as needed to apply the 

changes. 

 

 
 

 

If you do not want the program to automatically check for updates on start-up. You can 

disable auto update from the main menu option Edit->Options: 

 



 
 

When you select the option, the following window will pop up: 

 

 
 

 

On the general tab in the options window. If you disable automatic update at start up from the 

option, you can check for updates manually at any time from the About-> Check for updates 

menu item: 

 

 



 

The menu item will give you a user friendly wizard for program updates. The wizard will 

guide you through the update process, including download of the files, get an overview of 

what's new in the program etc. 

 

 

Other options 
 

In the options window (Edit->Options on the main menu), you can define your own 

departments (used in the job window and spare part window), job types (used in job window) 

and spare categories (used in spare part window). 

 

 

  

Reports 

 

 
 

 
There are currently 8 reports available in the program. The reports are: 

 

- Certificates: The 112 component is a special component in this system. It is reserved for 

certificates, and with this report you will get an overview of all certificate components. 

 

- Completed jobs (history): Get a list of jobs completed in a set interval (from date - to date) 

or based on today's date and running hours expired. The report is grouped by component and 

job. 

 

- Component list: Get an overview of all main components and subcomponents in the system. 

 

- Job orders: Get an overview of jobs that have expired, or will expire within the date or 

running hour that you specify as search criteria when you run the report. 

 

- Running hour main list: Get an overview of components that have been added to the running 

hour main list, with the running hour today listed next to the component. 

 



- Spare parts cost: The spare parts cost report, give you an overview of the consumed spare 

parts. The report is grouped by date, and can see a subtotal of the days cost. Filters in the 

report include date from - to, supplier, department and category. See spare parts section above 

for more info about this report. 

 

- Spare parts overview: Spare parts overview. The report is grouped by component name. 

 

- Supplier list: Here you get an overview of the name, address, fax and phone number and 

email to all the suppliers added to the system. 

 

 

On some of the reports, there are filters where you can reduce the results in the report by 

entering values in the filter dialog box that pops up, before the report is displayed: 
 
 

 

 

 

 
In the report window you will have several options to view the report: 

 

 
 

First icon on the icon group above, is for printing the report. The second for saving the file 

(currently can save the file as PDF), third icon is for export to PDF. On the PDF export dialog 

box, you do not need to change any of the default options, just click export to create the file. 

The last icon is for searching the document. 

 

For search, you enter the text in the window and hit find. To find next match in the document 

press F3 to find the next occurrence. 

 

 
 

On the next group of buttons you can zoom in and out. In addition to make the page full 

screen mode. To exit full screen mode, right click on the report and select the "Full screen" 

option. 

 



 
 

On the next group of buttons below 

 

 
 

The first button in the group is for group outline, the second button is for showing thumbnails 

on the left hand side of the report, as below: 
 

 
 
Click on the button again to remove the thumbnails view. The last button in the group above 

is for printer options. 

 
The final group of buttons in figure below 

 

 
 

are for navigating the pages in the report. 
 

 

 

User admin and rights 
 

The user management functionality lets you define users and their rights in the system. This 

way, it is possible to have different users with the right to perform different actions in the 

system. 

 

When defining initials for a user. Those initials will be used everywhere, to track who have 

performed the actions in the system. 

 

When first installing the program. There is only one user, the admin user. This user, have the 

right to perform all actions in the program. The password is initially, also, not set for this user, 



so that when you start the program, no login screen is displayed. If you want the program to 

display the login screen, so that the admin have to provide password, just set the password 

from the user admin settings window by editing the user from the list (see screen below): 

 

 

 
 
You can also set the initials for the admin user edit user screen. Otherwise it is not possible to 

change anything else for the admin user, because this user is a special user in the system, and 

need to have all the user rights.  

 

You can create additional users that might have all rights or limited amount of rights to 

perform different actions in the system (see overview of rights below). In the figure below is 

an example of a new user created in the system:  

 



 
 

 
You can currently set the following rights: 

 

- Add, edit, delete components 

- Add unscheduled events 

- Edit specifications 

- Add, edit and delete jobs 

- Sign out jobs 

- Postpone jobs 

- Add, edit and delete spare parts 

- Create backup 

- Restore backup 

- Send data to server 

- Add, edit and delete suppliers 

- Change user rights 

- Add, edit and delete running hours  

 

 

 

 



Logging events 

 
Some events are logged in the system. The events include when jobs are deleted, job name 

change, when running hour main list change, when unscheduled events occur and when job 

interval or expire info change. The events logged can be found under the history tab or job 

analyses window under the job tab (see job analysis section for more information). 

 

Deleted jobs are marked with stroked out text, other logged events are marked with grey text 

in the list (see figure below for some history of one component). 
 

 
 

 

 

 

Send data to office (server) 
 

With the send data functionality, you can send the data from the boat version to an office 

version that can keep track of the data from all of the vessels. The office version, also have 

built in functionality to send out notifications when data is about to expire (it is possible to set 

the interval) or have already expired. This way, you will never have to forget to do 

maintenance on the specified date. 

 

After you press the send data button, the window below will appear: 
 

 
 

 



It will let you know if the data was sent OK, how big the resulting file was and if there were 

any issues sending it to the server. 

 

This is how the office version looks like when it is waiting to get connections from the 

vessels. 
 

 


